Forum Title: Trouble with gas water heater
Hello, hopefully someone can help I bought a new 40 Gal rheem gas water heater about a year ago for a remodel, things got put on hold for a while and the tank sat in the box for a year. I have now had the new tank hooked up and when I tried to light it today It will not ignite. It has the Honeywell control valve on it and the pilot lights fine every time but then I get 5 flashing red lights which according to manual means water temp sensor failure. Am I missing something or do I possibly have a faulty part on this new water heater. Gas furnace and stove work fine wouldn't believe it to be a gas issue. Anybody else had this issue. Thanks in advance!!
Category: Plumber Post By: FRANK YOUNG (Decatur, AL), 09/27/2016

flame sensor is dirty, dusty, from sitting up turn on the water to tank, turn on a faucet in the house,,,let the system fill and purge air remove/ replace T&P ,,,, on the next one,,leave it alone, do not open it bleed air at faucet turn the t stat to economy see if that works

- LEONA GROSS (Hanover Park, IL), 09/19/2017

Is it a standard vent? And did you fill it before you tried to fire it? Not being a smarty pants but even the best of us get sidetracked

- KATHY WARD (Spokane Valley, WA), 10/06/2017

yes tank was filled but apears the tank may have some air in, the pressure releif valve will shoot out water even if the supply is shut off to tank. So maybe tank isn't filling all the way

- TARA LOWE (Charlotte, NC), 10/07/2017

Homeowner Resource Guide & Helpful Links

requestaquote Get Free Quotes callnow 888-880-2779